Free jQuery Business Company Joomla 2.5 Template

Preview Download
2.5

If you would like something special for your business website, here is a professional looking joomla 2.5 template for free. This great template can be used for company presentation, service provider websites, corporation websites and many others. The template has a lot of in built features like superfish drop-down menu, scroll to top button, customizable logo and site description, everything managed from template parameters. This theme allows you to display slideshows on your site, having a dedicated module position for that. Our demo page is using our custom developed slideshow module available for download on our site.

The template is loading by default the jQuery library’s latest version. This may cause conflicts if you may want to use other extensions that are built with jQuery. To avoid any javascript conflict, please load the jQeury only once. In the template parameters you can activate or deactivate the plugin.

When setting up our NivoSlider module, please keep the jQuery enabled on the template and disabled on modules. This way you can use the sliding down menu effect and also the scrolling effect on all pages.

If you would like to change the template background or link colors, form blue and orange to anything else, please edit the styles.css file.

Share on FacebookShare on Google+Tweet about this on TwitterShare on LinkedIn

After installing, I couldn’t find it in the template manager area!

    If the template was successful installed, then it have to be in the template manager.

Trying to get the slideshow to work…. how do i go about that with my own images… even when i select the right images.

    1. For this template we used the NivoSlider module that is available for download on our website.
    2. If you are using this template combined with the NivoSlider module, you have to deactivate the jQuery plugin in the module and load the javascript library through the template.

    Loading 2 jQuery libraries may cause conflicts and this is why your slideshow my not show up.

I keep getting error messages when I publish main or top menu:

Notice: Undefined variable: currentitemcount in C:\xampp\htdocs\templates\fjt004_j25\html\mod_menu\default.php on line 36

Notice: Undefined variable: lastdeeper in C:\xampp\htdocs\templates\fjt004_j25\html\mod_menu\default.php on line 41

Any suggestions?

    What Joomla version are you using? Also do let me know the php and apache version.

Wonderful Template! Much cleaner looking and faster load times than my previous templates.

I’m running Jomsocial 2.6 and if you try to create a discussion post, announcement, or anything else that uses and “editor”. The editor pops up in the Slideshow area and acts like a separate page. Any editor I try (JCE, TinyMCE, Jomsocial editor, etc) will not integrate.

When I switch back to my other templates as default, the editors all populate accurately, so my guess is that it’s something with this template. you can email me if you want more info.

    Try to deactivate the jQuery library loaded by the template. I’m not sure if this is the problem, please let me know if this helps. Or write here more details about the issue.

I have installed the xampp-win32-1.7.7-vc9-installer

PHP Version: 5.3.8
Web Server: Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1

Joomla: 2.5.1 Stable

I have tried to deactivate jQuery both on template and Nivoslider but I still have the error messages.

Hi! Great template, but I have the same problem as Casper. I have these errror messages in my top menu:

Notice: Undefined variable: currentitemcount in C:\wamp\www\myjoomlaweb\templates\fjt004_j25\html\mod_menu\default.php on line 36
Call Stack
# Time Memory Function Location
1 0.0010 346896 {main}( ) ..\index.php:0
2 0.7085 10668352 JSite->render( ) ..\index.php:48
3 0.7369 10894016 JDocumentHTML->render( ) ..\application.php:261
4 0.7369 10894016 JDocumentHTML->_renderTemplate( ) ..\html.php:433
5 0.7501 10987128 JDocumentHTML->getBuffer( ) ..\html.php:655
6 0.7502 10987504 JDocumentRendererModules->render( ) ..\html.php:371
7 0.7503 10988096 JDocumentRendererModule->render( ) ..\modules.php:39
8 0.7508 10989848 JModuleHelper::renderModule( ) ..\module.php:106
9 0.7557 11048032 include( ‘C:\wamp\www\myjoomlaweb\modules\mod_menu\mod_menu.php’ ) ..\helper.php:175
10 0.8348 11304136 require( ‘C:\wamp\www\myjoomlaweb\templates\fjt004_j25\html\mod_menu\default.php’ ) ..\mod_menu.php:25

Notice: Undefined variable: lastdeeper in C:\wamp\www\joomlamanuel\templates\fjt004_j25\html\mod_menu\default.php on line 41
Call Stack
# Time Memory Function Location
1 0.0010 346896 {main}( ) ..\index.php:0
2 0.7085 10668352 JSite->render( ) ..\index.php:48
3 0.7369 10894016 JDocumentHTML->render( ) ..\application.php:261
4 0.7369 10894016 JDocumentHTML->_renderTemplate( ) ..\html.php:433
5 0.7501 10987128 JDocumentHTML->getBuffer( ) ..\html.php:655
6 0.7502 10987504 JDocumentRendererModules->render( ) ..\html.php:371
7 0.7503 10988096 JDocumentRendererModule->render( ) ..\modules.php:39
8 0.7508 10989848 JModuleHelper::renderModule( ) ..\module.php:106
9 0.7557 11048032 include( ‘C:\wamp\www\myjoomlaweb\modules\mod_menu\mod_menu.php’ ) ..\helper.php:175
10 0.8348 11304136 require( ‘C:\wamp\www\myjoomlaweb\templates\fjt004_j25\html\mod_menu\default.php’ ) ..\mod_menu.php:25

I am using joomla 2.5.1
Php version 5.3.8
Apache version 2.2.21

jQuery–> Disable
Superfish Menu Effect–> Disable

Thanks for your help

    This problem is not caused by jQuery.

    I see, you both are using localhost servers, and this may be a problem. You see on our live demo server, everything works fine.
    My suggestion is to do the following changes:

    1. find the php.ini file in the wamp/xampp installation
    2. for error reporting use the following code: error_reporting = E_ALL & ~E_NOTICE

    NOTE: you may find the code with a semi-colon in the front ; error_reporting = E_ALL & ~E_NOTICE , semi-colon is for comments, you have to remove it. Please check if the error_reporting code is not used multiple times in the php.ini file. It is possible to be in use already in this way: error_reporting = E_ALL.

    3. restart your localhost server!!!

Ok, I had someone help me that knows more that I do about Jquery. And he fixed my problem with the text editors displaying in the Slideshow area rather than the Forum Post text box. (I’m using TinyMCE as my website editor, but it applies to any editor I’ve tried)

This is what he wrote back:
———————————————————————
javascript basically works by targeting IDs on a page in the DOM.

In this case, the ID targeted by TinyMCE is ‘message’
The problem seems to be that your template has two IDs with the name ‘message’
Hence, TinyMCE is targeting the first instance it finds.

On line 79, I changed

to

——————————————————-

I hope this helps others with a similar issue….

——————————————————-

    Jason, thank you for your comment, and I really appreciate posting this comment. I’m sure many other users will help this very useful.

    Regarding the changes you made, could you send me an email with the code you posted on the other replay, because the comment system filter out php codes, and does not allow you to post this type of messages. I will update your post as soon as I have your message.

    Thanks again for your valued replay.

the comments extension removed the html markup I put in the above post. I tried using “#” to remark it out here. Not sure if it’s showing.
——————————————————
On line 79, I changed

#
#
#

to

#
#
#

Hi! I really need some help!

I installed the template + nivo slider but it seems there is an conflict, the slideshow isn’t displaying any images. You said that jQuery should be “enabled on the template and disabled on modules” and that’s what I did. To be sure no jquery is interfering from the modules I unpublished them all but Vinaora nivo slider. After this I have set jquery source to none (from the nivo module) and enabled jquery from template. The problem still persisted.

I tried to disable jquery from the template and enable it from slideshow module and worked, but I want the template’s effects to work as well.

Thanks in advance!

    Hello,
    Are you using any other module that may use jQuery library? You have to disable jQuery on all modules if you load it through the template. NivoSlider may have conflict with other modules, is use, and this may causing the conflict. Please check again and do let me know.

Thanks so much for your help, put it doesn`t work. I remove the semi-colon in:
error_reporting
Default Value: E_ALL & ~E_NOTICE

and in
error_reporting = E_ALL

but now i have a blank page with this message:”Database connection error (1): The MySQL adapter ‘mysql’ is not available.”

Thank you again for your help

Can i have the link for the download of NivoSlider module. I can’t find it?
The template dosen’t work…

    In the extensions section you can find the NivoSlider module.
    What you mean about ‘The template dosen’t work…’ it has an error or you can’t upload or what does not work?

Hello, guys!

I activated the theme, but unfortunately instead of the nice picture I saw above, it gives me:

“Upgraders
If you are an experienced Joomla! 1.5 user, this Joomla! site will seem very familiar. There are new templates and improved user interfaces, but most functionality is the same. The biggest changes are improved access control (ACL) and nested categories. This release of Joomla! has strong continuity with Joomla! 1.6 while adding enhancements.”

Can u please guide me through theme applying process. I am a freshener.

For u future concerns I am using Joomla 2.5.2 and installed:
Piecemaker 2 – Joomla 2.5 Module
Joomla 2.5 Slideshow Module

Best regards,
James!

    It is not enough to install the template and the modules, you have to create modules in the Module Manager and assign them to the module positions available on the template.
    Also when using a slideshow module, you have to set it up: choose image folder, set up the dimension of the module and images, etc…

    Maybe it is a longer process, but this is the only way you can get the same view as on our demo.

NivoSlider module. Nothing whit this name. Maybe is my fault. 🙁

What Are Your Thoughts?

Your email address will not be published. Required fields are marked *