Piecemaker 2 – Joomla 2.5 Module

Preview Download

We developed a new slideshow module for Joomla 2.5 based on the popular Piecemaker 2 Image Rotator by Modularweb.net. The module is easy to install and use, allowing you to set up the dimension of module and images, to create custom transaction effects and durations and create up to five slides.

The original Piecemaker support video and flash, but unfortunately our module does not. We created this module for simplicity, adding video and flash support would be useless for most of Joomla users.

This module has lots of parameters, here is a preview of a Slide parameter setup.
piecemaker2 parameters

You can find the documentation of the Piecemaker 2 here.
If you have any problem setting up this module or you found a bug, please write a message below.

Share on FacebookShare on Google+Tweet about this on TwitterShare on LinkedIn
Bryan Nazar March 6, 2012 Reply

I downloaded the piece maker 2 module but is not working.. please help me what i am doing wrong.

I have just tried this module and it seems to work on chrome but not ie9… any ideas?

    What is the problem on IE9? There are styling problems or the module does not load at all in Internet Explorer 9?

I think the module is loading as the space is being assigned and when you right click the area it comes up with the flash tooltip. Have a look for yourself at pixelpeasant dot com

I have changed the module now and i’m using a jquery one as compatibility with smartphones is of high priority.

Hello, is coming to install the templates and maker of piece at the start of the locally installed Web site, the following error message like this

Notice: Undefined variable: xml2 in D:\xampp-win32-1.7.7-VC9\xampp\htdocs\joomla\modules\mod_nanopiecemaker2\mod_nanopiecemaker2.php on line 103

Notice: Undefined variable: xml3 in D:\xampp-win32-1.7.7-VC9\xampp\htdocs\joomla\modules\mod_nanopiecemaker2\mod_nanopiecemaker2.php on line 151

Notice: Undefined variable: xml4 in D:\xampp-win32-1.7.7-VC9\xampp\htdocs\joomla\modules\mod_nanopiecemaker2\mod_nanopiecemaker2.php on line 156

Notice: Undefined variable: xml5 in D:\xampp-win32-1.7.7-VC9\xampp\htdocs\joomla\modules\mod_nanopiecemaker2\mod_nanopiecemaker2.php on line 160

how can this be fixed?

I seem to have the same problem as Daniel with IE. in chrome it loos good, or actually better. In chrome the block in the middle with the options to play or show info dont show up. In IE I see them buttons, but only half, and in the bottom. I can turn around a block, but my text wont appear. Alse in IE only 1 picture appears.

I got problem with installation of this module. I try to do it in normal way, I mean: Extension Manager>Install from Directory>

Whatever, I still have got a report: “Please enter a package directory”. I put there full path to folder with this package. It doesn’t work either from my PC nor server :/ I have joomla 2.5

    Maybe you are doing something wrong. Why you not install it normally? Try Upload Package File, browse and select the file you want to install.

I’ve just fixed my problem. The problem were permissions of this folder. I changed them on www-data and now installation is done.

    I’m not sure if this can be changed or not, but anyway you have to edit the flash file that is provided by the Piecemaker 2 developer (modularweb.net)

I am also having problems with, the buttons with info, link etc. will not change size on IE9 and there is no info-text, when I click the info button. This works fine in Chrome, FF. (works in IE8)

Another problem for all browsers are that the flash-module does not work for other menus than the main menu. The flash is loading and the area is there, but the module doesn’t show.?

Example on svf.joergenogmaja.dk – try the menu link HOME (works) and menu link FORSIDE (flash does not work)

    There is no solution yet for IE9 fix. As soon as the Piecemaker 2 developer will update and fix this problem, we will also update our module.

    Next week, we will release a new module that use the Piecemaker 1 framework, and you may consider using that module until this IE9 problem will be fixed.

hi i have installed teh modul with no problems, everything is fine, but when i load soem pictures in this modul and embedding the modul in my site there is only a space area i nwhich the modul should be , but no pictures or anything else. whats my mistake ? i use the modul with the ebussines 1.6 template

    What browser are you using? With IE9 there is a minor bug.
    Also remember to set the cache time to 0 when setting up the module and set back to 900 when you are done with the changes.

I using FF 10 and IE 9, i think i have the similar problem from Daniel (“I think the module is loading as the space is being assigned and when you right click the area it comes up with the flash tooltip. Have a look for yourself at pixelpeasant dot com”)

in this position, where the modul should be, is only a empty space and right click on the space open the flash tool tip.
what can i do ?

    Can you please add some description to each slide? I’m not sure which is the problem yet. Please add some text to each image to see if this helps.

What Are Your Thoughts?

Your email address will not be published. Required fields are marked *